logo-responsive
Welcome, Guest
Username: Password: Remember me

TOPIC: Solved: Google font and https

Solved: Google font and https 5 months 2 days ago #14647

  • maxilgatto
  • maxilgatto's Avatar
  • Offline
  • Fresh Boarder
  • Posts: 13
  • Thank you received: 3
  • Karma: 0
Dear sir, I have trouble in moving my site (template Joomlage0071-simplex) from http to https (mixed content). In template global setting
I choosed the Google Lato Font.
Actually the problem seems to depend from font googleapis address.
Checking my site with a SSL checking tool I receive for every (obviously) page the message: page with unsecure content "mysite.it :
fonts.googleapis.com/css?family=Lato:300,400

fonts.googleapis.com/css?family=Oswald:300,400.
Of course the first link is an https and the other are http
How and where can I change http in https in order to use google fonts? Thanks
Last Edit: 4 months 4 weeks ago by maxilgatto.
The administrator has disabled public write access.

Google font and https 5 months 18 hours ago #14653

  • JohnO
  • JohnO's Avatar
  • Offline
  • Administrator
  • Posts: 5063
  • Thank you received: 828
  • Karma: 95
Hello Maxilgatto,


SOLUTION - Google fonts loading when using https
When you are using https then do the following.
Open the following file in your template php/styles.php
Do a find for all instances of
http://fonts.googleapis
and replace with
https://fonts.googleapis

Thanks,
JohnO
The administrator has disabled public write access.

Google font and https 4 months 4 weeks ago #14656

  • maxilgatto
  • maxilgatto's Avatar
  • Offline
  • Fresh Boarder
  • Posts: 13
  • Thank you received: 3
  • Karma: 0
Works fine, thanks
The administrator has disabled public write access.
The following user(s) said Thank You: JohnO

Google font and https 4 months 3 weeks ago #14662

  • JohnO
  • JohnO's Avatar
  • Offline
  • Administrator
  • Posts: 5063
  • Thank you received: 828
  • Karma: 95
You are welcome,

Thanks,
JohnO
The administrator has disabled public write access.

Google font and https 1 month 5 days ago #15232

  • AlainR
  • AlainR's Avatar
  • Offline
  • Fresh Boarder
  • Posts: 2
  • Thank you received: 1
  • Karma: 0
Note for dev : delete "http:" and let only "//" and following and http AND http will work fine!
The administrator has disabled public write access.
The following user(s) said Thank You: JohnO
Time to create page: 0.220 seconds
Powered by Kunena Forum

Use code   JAN19 at checkout

     January    

10% off Everything!

Cookies make it easier for us to provide you with our services. With the usage of our services you permit us to use cookies.
Ok